1. Что представляет собой массив в Паскале?
1. Структурированный тип данных, состоящий из фиксированного числа элементов, отличающихся типом.
2. Структурированный тип данных, представляющий набор взаимосвязанных по какому-либо признаку или группе признаков объектов, которые можно рассматривать как единое целое.
3. Упорядоченное множество однотипных переменных, которым можно присвоить общее имя, различающихся номерами.
4. Структурированный тип данных, представляющий последовательность взаимосвязанных по какому - либо признаку объектов.
2. . Что представляет собой массив в Паскале?
1. Структурированный тип данных, состоящий из фиксированного числа элементов, отличающихся типом.
2. Структурированный тип данных, представляющий набор взаимосвязанных по какому-либо признаку или группе признаков объектов, которые можно рассматривать как единое целое.
3. Упорядоченное множество однотипных переменных, которым можно присвоить общее имя, различающихся номерами.
4. Структурированный тип данных, представляющий последовательность взаимосвязанных по какому - либо признаку объектов.
3. Почему при поиске какого-либо элемента в массиве нельзя обойтись без цикла?
1. потому что задано условие поиска
2. потому что массив состоит из ограниченного числа элементов
3. потому что любое действие с массивом заключается в том чтобы перебрать все элементы или по крайней мере какую-то их часть
4. потому что обращение к каждому элементу массива идет по его имени и по индексу
4. Имеется описание var с: array [1..7] of integer;
Для хранения массива с будет отведено … последовательных ячеек памяти объёмом … байтов.
1. 7,80 2. 7,14 3. 14,7 4. 7,8.
4. В каком из предложенных описаний нет ошибок?
1. c:array(1..30) of integer;
2. d:array[1..30] integer:
3. f:array[1..30] of integer;
4. b:[1..30]of integer:
5. Каким осуществляется ввод элементов в следующем фрагменте? for i:=1 to n do a[i]:=random(50);
1. с датчика случайных чисел
2. с клавиатуры
3. присвоением заданных значений
4. прочтением из файла
6. Каким образом выведется массив на экран монитора? For i:=1 to n do write (a[i,], ‘ ‘);
1. По столбцам 2. По строкам 3. Ничего не выведется
7. Массив описан следующим образом: const b: array [1..5] of integer = (1, 2, 2, 1, 5);
Определите значение выражения b[2] * b [5] + b [4] = …
8. Заполните массив в тетрадь. Чему равна сумма a[4] и a[5] Элементов массива, сформированного следующим образом: For i := 1 to 5 do a[i] := i*(i+1);
9. Определите, что будет напечатано в результате выполнения следующего алгоритма при имеющихся исходных данных (-3, -2, 5, 7, 1, 6, 5):
program Example;
var a: array [1..7] of integer; S, i: integer;
begin
for i := 1 to 7 do
read (a[i]);
S := 0;
for i := 1 to 7 do
if a[i]<0 then S := S + a[i];
writeln (S)
end.
Начертите в тетради и заполните таблицу:
i
a[i]
S
Чево чотта не панемая скин по схему или фото