В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

1. Изучить программу https://prnt.sc/s2817y 2. Написать программу по следующему условию: https://prnt.sc/s282a1

Показать ответ
Ответ:
Fedor122790
Fedor122790
13.08.2022 15:54

var  

x, y: integer;

n: integer;

sum: integer;

mindif: integer;

f: text;

begin

   assign(f,'C:\27-A.txt');

   reset(f);

   readln(f, n);

   sum := 0;

   mindif := 20001;

   while not eof(f) do begin

       readln(f, x, y);

       if x > y then  

           sum := sum + x

       else  

           sum := sum + y;

       if (abs(x - y) < mindif) and (abs(x-y) mod 3 <> 0) then mindif := abs(x-y);

   end;

   if sum mod 3 <> 0 then

       writeln(sum)

   else

       writeln(sum - mindif);

end.

Объяснение:

0,0(0 оценок)
Ответ:
mares2007
mares2007
17.07.2022 10:37

a = 1; b = 4; c = 7

a = 1; b = 7; c = 4

a = 4; b = 7; c = 1

a = 4; b = 1; c = 7

Объяснение:

Вот код программы на C++:

#include <iostream>

using namespace std;

void main()

{

setlocale (LC_ALL, "RUS");

int a, b, c, M;

cout << "Введите число а: ";

cin >> a;

cout << "Введите число b: ";

cin >> b;

cout << "Введите число c: ";

cin >> c;

if (a > b)

{

 M = a;

}

else

{

 M = b;

}

if (c > b)

{

 M = c;

}

else

{

 M = b;

}

cout << "Наибольшее число: " << M << endl;

}

Можешь сам(а) на онлайн-компиляторе проверить выражения, если не уверен(а).

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота