В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Ychenik1354
Ychenik1354
20.07.2020 08:16 •  Информатика

1)Написать программу для поиска решения задачи. Плата за одного быка составляет 20 гривен, за корову - 10 гривен, за теленка - 1 гривна. Сколько можно купить быков, коров и телят, если на 200 гривен надо купить 100 голов скота?

2)Написать программу для поиска решения задачи. Сколько в зоопарке страусов и верблюдов, если вместе у них 40 ног?

3)написать программу для поиска решения задачи. Найдите все двузначные числа, которые делятся на произведение их цифр.

Язык программирования Python

Показать ответ
Ответ:
tiamaressp035gw
tiamaressp035gw
06.02.2023 07:09

ЗАДАНИЕ  1

1 Абу́ Абдулла́х (или Абу Джафар) Муха́ммад ибн Муса́ аль-Хорезми́ (перс. بن موسی خوارزمی‎, араб. أبو عبد الله محمد بن موسی الخوارزمی‎; ок. 783 — ок. 850) — среднеазиатский учёный IX века, математик, астроном, географ и историк. Благодаря ему в математике появились термины «алгоритм» и «алгебра».

2 Дж. Буль опубликовал работу «The Mathematical Analysis of Logic» («Математический анализ логики»), а в 1854 г.— «Ап Investigation of the Laws of Thought…» «Исследование законов мышления»). В них Буль изложил основы своей алгебры логики, где применил алгебраическую символику для записи логических операций и логических выводов. Булева алгебра логики в виде исчисления классов явилась первой системой математической логики. Основным результатом Булевой алгебры отмечается то, что теперь не ограничиваются применением символики к логике, а строят специальные логические исчисления; логические законы выступают в алгебре логики как необходимый момент формализованных систем.

3 Intel 4004 — 4-битный микропроцессор, разработанный корпорацией Intel и выпущенный 15 ноября 1971 года. Эта микросхема считается первым в мире коммерчески доступным однокристальным микропроцессором.

4 В 1820 году Шарль Ксавье Тома де Кольмар создал первое серийно выпускавшееся механическое счётное устройство — арифмометр Томаса, который мог складывать, вычитать, умножать и делить. В основном, он был основан на работе Лейбница.

Объяснение:

0,0(0 оценок)
Ответ:
NurseRedheart
NurseRedheart
23.03.2020 10:57

function fibonacchi(x:integer):integer;

// функция возвращает порядковый номер введённого числа

// ряда Фибоначчи. Если число не является элементом

// из данного ряда, то функция возвращает -1

var counter:integer = 2;

   s1,s2,s3:integer;

begin

   s1 := 0;

   s2 := 1;

   s3 := 0;

   if x = 0 then fibonacchi:=1

   else if x = 1 then fibonacchi:=2

   else begin

       while s3 < x do begin

           s3 := s1 + s2;

           s1 := s2;

           s2 := s3;

           inc(counter);

       end;

       if s3 = x then fibonacchi:=counter

       else fibonacchi:=-1;

   end;

end;

begin

   write(fibonacchi(13));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота