В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
valera122004
valera122004
16.03.2020 02:43 •  Информатика

1.написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов. значения элементов массива вводятся пользователем. 2.написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел.

Показать ответ
Ответ:
Лешик2005
Лешик2005
08.10.2020 15:05
1.
var
mas: array[0..10] of Integer ;
i,min,j: Integer;

begin
min:=0;
writeln('Введите числа:');
for i := 1 to 10 do begin

ReadLn(mas[i]);
if (mas[i] <0)
then j:=mas[i];
if j then min:=j;
end;
WriteLn('Минимальное отрицательное число:',min);

end.

2.
var
mas: array [0..10] of Integer;
i, max, j: Integer;

begin
writeln('Введите числа:');
for i := 1 to 10 do
begin
ReadLn(mas[i]);
if abs(mas[i - 1]) < abs(mas[i]) then
max := mas[i] ;
end;
WriteLn('Наибольшее по модулю число:', max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота