В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
levkamorkovka
levkamorkovka
04.01.2023 06:09 •  Информатика

1) написать программу, вычисления значений функции y=1/x+2 с шагом 0,1. значения аргумента беруться из [-1; 2) заполнить таблицу значений функции y=sqrt(1/2x-1)+2 c шагом 0,1. значения аргумента беруться из [0; 3,8]. предстоит продумать вопрос вывода найти значение x, при котором функция не определена..

Показать ответ
Ответ:
oznobiseva2006
oznobiseva2006
30.09.2020 14:09

 

 

program P1;
uses
crt;
var
x,y : real;
begin

clrscr;

x := -1;

writeln('');

while x <= 1 do
begin

y := 1/x+2;

x := x + 0.1;


writeln(y);

end;

writeln('');

writeln('');

x := 0;

writeln('');

while x <= 3.8 do
begin

if (x <> 0) and (1/(2*x)-1 >= 0) then
y := sqrt(1/(2*x)-1)+2 else
writeln('Pri X = ',x,' ne opredelena');

x := x + 0.1;


writeln(y);

end;

writeln('');

readln;
readln;

 


end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота