В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
mariamyp
mariamyp
27.06.2022 04:26 •  Информатика

1) напишите программу, которая организует массив из 10 целых чисел по случайному закону в интервале от 0 до 200. и определяет сумму элементов массива кратных 5. на экран выводятся элементы созданного массива в строку с форматом 4, элементы , значение которых кратно 5 и сумма. используйте 2 цикла.

Показать ответ
Ответ:
петлю
петлю
10.10.2020 13:18

var

 a: array [1..10] of Integer;

 i, s: Integer;

begin

 Randomize;

 s := 0;

 for i := Low (a) to High (a) do begin

   a [i] := Random (201);

   Write (a [i] :4);

 end;

 WriteLn;

 for i := Low (a) to High (a) do begin

   if a [i] mod 5 = 0 then begin

     s := s + a [i];

     Write (a [i] :4);

   end;

 end;

 WriteLn;

 WriteLn ('Сумма = ', s);

 ReadLn;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота