В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Wonderfulgirl30
Wonderfulgirl30
14.05.2023 06:59 •  Информатика

1)Напишите программу, которая переводит цифровую систему отметок в словесную. Например если пользователь ввел оценку "5", на экран выводится словесная отметка "Пятерка" 2)Напишите альтернативную программу с применением оператора if для 1-ой задачи

Показать ответ
Ответ:
KateySh
KateySh
21.03.2021 13:56

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

case i of  

1: writeln('Единица');  

2: writeln('Двойка');  

3: writeln('Тройка');  

4: writeln('Четверка');  

5: writeln('Пятерка');  

else writeln('Нет такой оценки');  

end;  

readln;  

end.

Альтернативная задача

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

if i = 1 then writeln('Единица')

else if i = 2 then writeln('Двойка')

else if i = 3 then writeln('Тройка')

else if i = 4 then writeln('Четверка')

else if i = 5 then writeln('Пятерка')

else writeln('Нет такой оценки');    

readln;  

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота