В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Otahalepi
Otahalepi
20.06.2021 11:04 •  Информатика

1.Составить программу на Паскале для вывода таблицы значений функции y = 12 x2+2 на отрезке [-4; 5] с шагом 1. На проверку нужно прислать код программы и результат работы в виде скриншота. 2.Найти сумму положительных, произведение и количество отрицательных из 10 введенных целых значений ( ):
-7; 12; 13,5; -2; 0; 16; -4; 10,3; 1; -10,3.
Код программы написать на Паскале.
3.Составить блок-схему алгоритма и программу на Паскале для обработки массива из 15 чисел. Вычислить произведение и количество элементов, не равных нулю и больше 5.
4.Написать программу на Паскале для решения задачи: дано целое число b и натуральное (целое неотрицательное) число m. Вычислить b в степени m. На проверку прислать код программы и результат работы кода в виде скриншота окна программы с введенными входными данными

Показать ответ
Ответ:
Amkissa
Amkissa
19.04.2022 20:06
Учитель даёт тебе закодированную информацию (чушь несет, которую ты постоянно слушаешь), ты ее воспринимаешь как слуховую (когда говорит) и как зрительную (когда рисует на доске). Ты эту информацию загоняешь в мозг, где производишь обработку (из бреда составляешь адекватные знания (информацию (т.е. то, что уменьшает твою неопределенность)). Правила обработки у тебя простые - игнорируешь гхмыканья, белиберду (то, что ты прослушала на уроке и не хватает умишка дотюнькать, о чем он говорит), а то, с чем ты имела дело и имеет связи-оставляешь на хранение. То, что ты оставляешь на хранение и является результатом обработки.Такой вид обработки относится к преобразованию информации. Очень просто можешь и написать о анализировании и синтезировании.
0,0(0 оценок)
Ответ:
Loader
Loader
02.01.2022 02:01
Const n=15;
Var a:array[1..n]  of integer;
i,indx,k,tr,indxx:integer;
Begin 
Randomize; 
 For i:=1 to n do  begin
  A[i]:=Random(40)-20; 
 Write(a[i],' '); 
   end; 
       Writeln; 
   write('0 имеет номер: '); 
     For i:=1 to n do   
Begin
 If A[i]=0 thenwrite(i);
 end;
Writeln;
indx:=0; 
 For i:=1 to n do 
  Begin
   If a[i] mod 2=0 then 
  begin 
  indx += 1; 
 a[indx]:=a[i]; 
  end; 
 end; 
    Write('Индекс четных элементов: '); 
 For i:=1 to indx do 
 write(a[i],' ');   
   For i:=1 to n do
    Begin 
   If A[i]<0 then
      Begin   
  inc(k);      
 end;      
   end;   
 Writeln;
 Writeln('Кoличество отрицательных элементов: ',k);
 For i:=1 to n do
  Begin 
 If A[i] mod 3=0 then 
 tr:=a[i];
  end; 
 Writeln('Кратное трем ',tr); 
   indxx:=0; 
 writeln('Индексы кратны 3: '); 
  For i:=1 to n do 
  Begin 
  If a[i] mod 3=0 then 
  begin   
   indxx += 1; 
 a[indxx]:=a[i];
   write(' ',a[i]); 
    end;   
 end;    
  end.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота