В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
MaryWintlstone
MaryWintlstone
02.08.2022 22:34 •  Информатика

1. Составить программу разложения натурального числа n на простые множители. Пример: 360 = 2 2 2 3 3 5. Решить задачу необходимо через цикл While и построить блок схему. 2. написать программу определения максимального числа последовательности положительных чисел. Решить задачу необходимо через «Любой Цикл» и построить блок схему.
3. Начав тренировки, спортсмен в первый день пробежал 10 км . Каждый день он увеличивал дневную норму на 10% от нормы предыдущего дня. Определить, какой суммарный путь пробежит спортсмен за 5 дней. Решить задачу необходимо через For и построить блок схему.

4. Для вещественных чисел z,x,y вычислить (x+y+x ) и (x*y*x ), определить что будет больше произведение или сложение .Решить задачу необходимо через if и построить блок схему.
5. По последней цифре заданного числа определить последнюю цифру куба этого числа.Решить задачу необходимо через Оператор выбора и построить блок схему.
Через Python

Показать ответ
Ответ:
klychkovs66
klychkovs66
12.03.2023 16:59

using System;

namespace NoNamespace.Task029 {

   //Напишите консольное приложение на C#, находящее пару чисел меньше N,  

   //сумма цифр которых одинакова, и сообщающее, если таких чисел нет

   internal class Program {

       private static void Main() {

           Console.WriteLine("Введите N");

           var n = int.Parse(Console.ReadLine());

           var sums = new int[n];

           sums[0] = 1;

           for (var i = 1; i < n; i++) {

               sums[i] = NumberSum(i);

           }

           var found = false;

           for (var i = 1; i < n; i++) {

               if (sums[i] == 0) continue;

               for (var j = i + 1; j < n; j++) {

                   if (sums[i] != sums[j]) continue;

                   Console.WriteLine($"Number sum {i} and {j} = {sums[i]}");

                   found = true;

               }

           }

           if (!found)

               Console.WriteLine("Nothing found");

           Console.ReadKey();

       }

       private static int NumberSum(int number) {

           var sum = 0;

           while (number > 0) {

               sum += number % 10;

               number = number / 10;

           }

           return sum;

       }

   }

}

0,0(0 оценок)
Ответ:
Осьминог13
Осьминог13
22.04.2022 02:54
PascalABC.NET 3.4.2, сборка 1884 от 24.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger;

 var a := arrRandom(n, 1, 100);

 a.Println;

 var p := BigInteger(1);

 for var i := 0 to n - 1 do

   if a[i] mod 2 = 0 then p := p * a[i];

 p.Println

end.

Пример90

67 13 96 10 94 24 16 2 43 94 60 60 56 88 28 27 75 32 90 18 70 32 6 23 81 57 38 73 25 6 20 52 56 33 38 79 20 81 67 49 33 29 43 36 74 46 13 14 30 93 72 8 10 99 89 35 8 73 30 37 86 43 78 38 75 9 4 24 50 49 8 95 65 42 85 42 90 71 50 35 45 25 44 33 34 13 43 57 45 4

752729749734296001571550469794689018400554807071967543296000000000000000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота