В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
6996nya
6996nya
22.09.2022 20:12 •  Информатика

1.составьте программу вычисления суммы цифр двузначного числа 2. составьте программу вычисления суммы цифр трёхзначного числа

Показать ответ
Ответ:
jhblhbuylpd
jhblhbuylpd
29.07.2020 07:10
Program znanija;
var a,s:integer;
begin
Read(a);
while a<>0 do 
begin   
s:= s + a mod 10;   
a:= a div 10 
end;
writeln(s);
end.

Работает для многозначных цифр не превышающих integer 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота