1
Создать массив на размером 10 элементов, заполнить массив с клавиатуры, в массиве
должны быть разные числа, как дробные , так и целочисленные. Найти и вывести на экран
в массиве те элементы, значение которых меньше среднего арифметического, взятого от
всех элементов массива.
2
Создать целочисленный массив размерностью 10 элементов, заполнить его с клавиатуры.
В массиве, содержащем положительные и отрицательные целые числа, вычислить сумму
четных положительных элементов.
3
Создать массив на размером 10 элементов, заполнить его с клавиатуры. Посчитать и
вывести на экран количество положительных элементов, отрицательных и элементов
равных значению «0». Если каких либо значений нет, то программа должна выдавать
надпись, что таких элементов массива нет!(Например: «Отрицательных чисел НЕТ»).
Г) логика
2. Повествовательное предложение, в котором что-то утверждается или отрицается называется:
В) высказывание
3. Константа, которая обозначается «1» в алгебре логики называется:
В) истина
4. Какое из следующих высказываний являются истинным?
В) II + VI = VIII (2 + 6 = 8, записанное при римских чисел)
5. Объединение двух высказываний в одно с союза «и» называется:
Б) конъюнкция
6. Чему равно значение логического выражения (1v1)^(1v0)?
А) 1 ((1 v 1) ^ (1 v 0) = 1 ^ 1 = 1)
7. Что такое логика?
B) это наука о формах и законах человеческого мышления и, в частности, о законах доказательных рассуждений
8. Логической операцией не является:
A) логическое деление
9. Объединение двух высказываний в одно с оборота «если..., то..» называется:
Г) импликация
10. Таблица, содержащая все возможные значения логического выражения, называется:
Б) таблица истинности
11. Даны три высказывания:
А = (Наступила осень)
В = (Мы учимся в колледже)
С = (Мы решаем контрольную работу)
Напишите в виде формулы высказывание: «Наступила осень, мы учимся в колледже и решаем контрольную работу»
ABC
12. Придумайте ложное высказывание, соответствующее функции и постройте таблицу истинности для следующей функции:
Х=А+ВС
В ответе выписать комбинации А, В, С при которых Х – ложно.
Например, если A = (Скопье – столица Черногории), B = (Скопье – столица Македонии) и C = (Скопье – столица Эфиопии), то X = A + BC соответствует ложному высказыванию "Скопье – столица Черногории или Македонии и Эфиопии".
Таблица истинности:
A B C X
0 0 0 0
0 0 1 0
0 1 0 0 – случай из примера
0 1 1 1
1 0 0 1
1 0 1 1
1 1 0 1
1 1 1 1
X ложно при (A, B, C) = (0, 0, 0), (0, 0, 1), (0, 1, 0).
#include <cmath>
using namespace std;
void main()
{
int n,sum=0;
float y,k=0;
cin >> n;
int *mass = new int[n];
for (int i = 0;i < n;++i)
{
cin >> mass[i];
}
for (int i = 0;i < n;++i)
{
if (mass[i] >0 )
{
k++;
y=pow(mass[i],2);
cout<<y;
sum+=mas[i]
}
}
system("pause");
}
2)#include <iostream>
#include <cmath>
using namespace std;
void main()
{
int s,p,r,day=0;
cin >> s>>p>>r;
float km=s;
while(r>km)
{
km+=km*p/100;
day++;
}
cout << " km = " << km << " day = " << day << endl;
system ("pause");
}