15.2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 6 и оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чисел, кратных 6 и оканчивающихся на 4.
c++
Объяснение:
#include <iostream>
using namespace std;
int main() {
int n,num,iter=0;
cin>>n;
for (int i=0;i<n;i++){
cin>>num;
if (num%6==0 && num%10==4)
iter++;
}
cout<<iter; //вывод
return 0;
}
var
n,x,i,counter : integer;
begin
counter := 0;
readln(n);
for i := 1 to n do
begin
readln(x);
if (x mod 10 = 4) and (x mod 6 = 0) then
counter := counter + 1;
end;
writeln(counter);
end.