В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
SanyaLe9
SanyaLe9
08.11.2021 01:22 •  Информатика

1cоставить программу,которая позволяет ввести строку s,затем после каждой буквы "а" вставить пробел. 2 составить программу,которая удаляет в строке s все буквы "о"

Показать ответ
Ответ:
hyyeblan5577
hyyeblan5577
26.06.2020 11:09
На всякий случай сделал проверку и на русские, и на английские.
задача 1.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='a') or (s[i]='а') then
s:=copy(s,1,i)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
задача 2.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='о') or (s[i]='o') then
s:=copy(s,1,i-1)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота