2 уровень сложности 1. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и среднее арифметическое элементов массива. 2. Написать программу, которая вводит массив из N целых чисел и выводит на экран сумму отрица- тельных элементов. Протестировать программу для следующих массивов: a) 35-2 3-2 0-6 -8 1 6) -1 -2-3-40-123 3. Написать программу, которая вводит массив из N целых чисел и выводит на экран сумму положи- тельных элементов. Протестировать программу для следующих массивов: а) 35-23 -20 -6 -8 1 6-1 -2-3-40-1 2 3 4. Написать программу, которая вводит массив из N целых чисел и выводит на экран произведение нечетных элементов. !Делать по схеме!
var mas1, mas2: array[0..9] of integer; t, k, i, j: integer; begin readln(t); readln(k); for j := 0 to 1 do begin if (j = 1) then writeln(); for i := 0 to 9 do begin if(j = 0) then begin mas1[i] := random(100); write(mas1[i], ' '); if mas1[i] > t Then mas1[i] := mas1[i] + 4; end else begin mas2[i] := random(100); write(mas2[i], ' '); if mas2[i] > 10 * K Then mas2[i] := mas2[i] + K; end; end; for i := 0 to 9 do if (j = 0) then write(mas1[i]) else write(mas2[i]); writeln(); end; readln(); end.
Объяснение:
Const n=12;
Var T:array[1..n] of real;
i,imax:integer;
sr:real;
Begin
writeln('Введите среднии температуры за каждый месяц года');
sr:=0;
For i:=1 to n do
Begin
read(T[i]);
sr:=sr+T[i];
End;
sr:=sr/n;
writeln('Среднегодовая температура = ',sr:0:2);
imax:=1;
For i:=2 to n do
if T[i]>T[imax] then imax:=i;
writeln('Самая высокая среднемесячная температура была в месяце');
writeln('под номером ',imax,' и составила ',T[imax]:0:2);
readln;
End.
Вроде так.
begin
readln(t);
readln(k);
for j := 0 to 1 do begin
if (j = 1) then writeln();
for i := 0 to 9 do begin
if(j = 0) then begin
mas1[i] := random(100);
write(mas1[i], ' ');
if mas1[i] > t Then mas1[i] := mas1[i] + 4;
end
else
begin
mas2[i] := random(100);
write(mas2[i], ' ');
if mas2[i] > 10 * K Then
mas2[i] := mas2[i] + K;
end;
end;
for i := 0 to 9 do
if (j = 0) then
write(mas1[i])
else
write(mas2[i]);
writeln();
end;
readln();
end.
))