2 задача. Программа анализирует введѐнное пользователем целое число Х и по
результатам проверки выводит на экран сообщения:
- если Х=0: «Число равно нулю»;
- «Число чѐтное»;
- «Число не чѐтное»;
Внимание! В программе обязательно должно быть реализовано вложенное ветвление.
Внимание! Для проверки чѐтности используйте функцию mod (если x mod 2 = 0 значит число чѐтное написать программу
Program DaNNuu;
uses crt;
const n=3;
var
a:array [1..n] of integer;
i,j,min,temp:integer;
begin
randomize;
{создание массива}
writeln('Элементы массива:');
for i:=1 to n do
begin
a[i]:=random(101)-50;
write (a[i]:5);
end;
{сортировка массива}
for i:=1 to n-1 do
begin
min:=i;
for j:=i+1 to n do
if a[min]>a[j] then
min:=j;
temp:=a[i];
a[i]:=a[min];
a[min]:=temp;
end;
writeln();
{вывод массива}
writeln('Результат сортировки:');
for i:=1 to n do
write(a[i]:5);
end.
#include<iostream>
using namespace std;
long double fac(int N)
{
if(N < 0) // если пользователь ввел отрицательное число
return 0; // возвращаем ноль
if (N == 0) // если пользователь ввел ноль,
return 1; // возвращаем факториал от нуля - не удивляетесь, но это 1 =)
else // Во всех остальных случаях
return N * fac(N - 1); // делаем рекурсию.
}
int main()
{
int N;
cout << "enter N: " ;
cin >> N;
for(int i = 0; i < N; i++)
cout << "a[ " << i << " ] = " << 1/fac(i) << endl;
}
данная программа вычисляет значения ряда, до N-го члена ряда