В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ян6
ян6
07.06.2021 07:00 •  Информатика

20.2 напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 4, или сообщает, что таких чисел нет (выводит no). программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести среднее арифметическое чисел, кратных 4, или вывести «no», если таких чисел нет. заранее .

Показать ответ
Ответ:
Золушка251
Золушка251
02.07.2020 23:20
Var  x, y, count, s: integer;
begin
repeat
if(y = 100) then break;
readln(x);
if(abs(x) > 300) then begin
writeln('Число по модулю не может быть > 300.');
continue
end
else
if(x mod 4 = 0) and (x <> 0) then begin
inc(count);
s := s + x;
end;if(x <> 0) then inc(y);
until(x = 0);
writeln('Среднее арифметическое: ', s / count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота