В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Krest007
Krest007
22.01.2023 22:03 •  Информатика

4.напишите программу ,которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел,не превосходящих 256.программа получает на выход целые числа ,количество введенных чисел неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность.)количество чисел не превышает 1000.введенные числа по модулю не превышают 30 000.программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел,не превосходящих 256.

Показать ответ
Ответ:
Danila251008
Danila251008
29.07.2019 18:30
Var x,k: integer;   begin  k: =0;   repeat  writeln('введите число');   read(x);   if (x> 0) and (x< =256) then k: =k+1;   until x=0;   writeln('количество положительных чисел < =256 = ',k);   end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота