В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ayazhankadyrov24
ayazhankadyrov24
04.06.2020 15:43 •  Информатика

4. Напишите программу, которая выводит на экран значения функции y= f(x). Аргумент x принимает значения от x1 до х2 с шагом Дх:
{y = {3 – x; x > 4; 3 + x, x<4;​

Показать ответ
Ответ:
dannovchern
dannovchern
23.10.2020 18:24
Const m=4; n=15;
var
  i,j,j0: integer;
  a:array[1..m,1..n] of integer;
  jExit,iExit:Boolean;
begin
  Randomize;
  for i:=1 to m do begin
    writeln;
    for j:=1 to n do begin
      a[i,j]:=random(2);
      write(a[i,j]:2)
      end
    end;
  writeln;
  j:=0; jExit:=false;
  repeat
    j:=j+1; i:=1; iExit:=false;
    if a[i,j]=0 then begin
      repeat
        i:=i+1;
        if a[i,j]<>0 then iExit:=true
      until iExit or (i=m);
      if i=m then jExit:=true
      end
    until jExit or (j=n);
  if a[i,j]=0 then writeln('Нулевой столбец ',j)
  else writeln('Нет нулевых столбцов');
end.

Тестовый пример:

 0 1 1 1 1 0 1 0 1 0 0 0 0 0 1
 0 0 1 0 1 0 0 0 1 1 0 0 0 0 0
 1 1 0 0 0 1 0 1 1 1 1 1 0 1 1
 1 1 1 0 1 0 1 0 0 1 0 1 0 1 0
Нулевой столбец 13
0,0(0 оценок)
Ответ:
st1rb1t
st1rb1t
30.05.2020 15:37
На Java:

class SearchPalin{
 public static void main(String args[]){
  String palinString = new java.util.Scanner(System.in).nextLine();
  System.out.print("\nПалиндром(-ы):\n  ");
  for(int wordStart = 0, wordEnd = 0; wordEnd<palinString.length(); wordEnd++)
   if(wordEnd+1==palinString.length() || palinString.charAt(wordEnd+1)==' '){
 String wordBeginning = "", wordEnding = "";
 for(int wordBe = wordStart;wordBe<wordEnd+1;wordBe++)wordBeginning+=palinString.charAt(wordBe);
 for(int wordEn = wordEnd;wordStart-1<wordEn;wordEn--)wordEnding+=palinString.charAt(wordEn);
 if(wordBeginning.equals(wordEnding)){
  for(int palinWord = wordStart;palinWord<=wordEnd;palinWord++)System.out.print(palinString.charAt(palinWord));
  System.out.print("\n  ");
 } wordStart = wordEnd+2;
   }
 }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота