В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Maci189
Maci189
08.07.2022 23:17 •  Информатика

50 ! .
в массиве из 15 вещественных чисел найти наибольший элемент и поменять его местами с последним элементом.
нужно составить программу для visual basic for application (vba).
заранее огромное ​

Показать ответ
Ответ:
егор673
егор673
10.10.2020 21:55

program laba;

{$APPTYPE CONSOLE}

uses

 SysUtils,

 windows;

var

 a:array[1..15] of integer;

 i,imax,x:integer;

begin

SetConsoleoutputCP(1251);

 for i:=1 to 15 do

begin

writeln('Введите',i,'-й элемент');

readln(a[i]);

end;

imax:=1;

for i:=2 to 15 do

if a[i]>a[imax] then imax:=i;

x:=a[15];

writeln('максимальное число = ',a[imax],' его индекс= ',imax);

if imax=15 then write('Он последний, обмена нет');

else

  begin

  x:=a[imax];

  a[imax]:=a[15];

  a[15]:=x;

  writeln('Обмен максимального и последнего:');

  for i:=1 to 15 do

  write(a[i]:6:3,' ');

  end;

 

readln;

end.

Объяснение:

0,0(0 оценок)
Ответ:
nik7710
nik7710
10.10.2020 21:55

Sub Swap()

   Dim r As Range, A As Variant

   Dim i As Integer, im As Double, n As Integer, t As Double

   n = 15

   Set r = Range(Cells(1, 1), Cells(1, n))

   A = r

   im = 1

   For i = 2 To n

       If A(1, i) > A(1, im) Then

           im = i

       End If

   Next i

   t = A(1, im)

   A(1, im) = A(1, n)

   A(1, n) = t

   Set r = Range(Cells(2, 1), Cells(2, n))

   r = A

End Sub

На лист в ячейки А1 - О1 заносим исходные 15 чисел

На этот же лист через проект помещаем макрос и запускаем.

Результат будет в ячейках А2 - О2

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота