52
написать программу на языке программирования python.
на вход подаётся число n, а затем n дробных чисел –
ежедневный курс доллара к рублю за последние n дней.
вывести стоимость
a. за которую было выгоднее всего купить доллар
b. за которую было выгоднее всего продать доллар
2005 : 8 = 250, остаток 5
250 : 8 = 31, остаток 2
31 : 8 = 3, остаток 7
3 : 8 = 0, остаток 3
Выписываем остатки в обратном порядке: 3725
В пятеричную
2005 : 5 = 401, остаток 0
401 : 5 = 80, остаток 1
80 : 5 = 16, остаток 0
16 : 5 = 3, остаток 1
3 : 5 = 0, остаток 3
Выписываем остатки в обратном порядке: 31010
В двоичную
2005 : 2 = 1002, остаток 1
1002 : 2 = 501, остаток 0
501 : 2 = 250, остаток 1
250 : 2 = 125, остаток 0
125 : 2 = 62, остаток 1
62 : 2 = 31, остаток 0
31 : 2 = 15, остаток 1
15 : 2 = 7, остаток 1
7 : 2 = 3, остаток 1
3 : 2 = 1, остаток 1
1 : 2 = 0, остаток 1
Выписываем остатки в обратном порядке: 11111010101
using namespace std;
int main() {
int a[50][2];
int n;
int k1=0;
int k2=0;
int k3=0;
int k4=0;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> a[i][0] >> a[i][1];
}
for (int i = 0; i < n; i++) {
if (a[i][1]>0)
if (a[i][0]>0) k1++; else k2++;
else if (a[i][0]>0) k4++; else k3++;
}
if ((k2>=3)or(k2==2)and(k1>3)or(k3>5)or(k4>9))
cout << "Clock is broken" << "\n";
else cout << k2 << k1 << ":" << k3 << k4 << "\n";
return 0;
}
Пример:
10
-1 1
1 1
1 2
-1 -1
-1 -2
-1 -3
1 -1
1 -2
1 -3
1 -4
12:34