В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Sultanika
Sultanika
14.07.2020 21:19 •  Информатика

58 за заполнение массива с паскаля нужно заполнить массив а(5,5) и распечатать его написать программу полностью

Показать ответ
Ответ:
sumanrahmatova
sumanrahmatova
10.06.2020 08:05

program raf105;

var

 a:array[1..5,1..5] of integer;

 i,j,o: integer;

begin

o:=-2;

for i:=1 to 5 do

begin

 writeln;

 for j:=1 to 5 do

 begin

   if (j<=3+abs(o)) and (j>=3-abs(o))

     then a[i,j]:=1

     else a[i,j]:=0;

   write(a[i,j],' ');

 end;

 o+= 1;

end;

end.

Язык PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота