60 . на с++
сжатие массива
напишите программу, которая выполняет "сжатие массива" – переставляет все нулевые элементы в конец массива. при этом все ненулевые элементы располагаются в начале массива в том же порядке.
входные данные
первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 1 .
выходные данные
программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.
примеры
входные данные
6
1 0 2 0 3 4
выходные данные
1 2 3 4 0 0
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "Rus");
int n, j;
cout << "введите длину массива ";cin >> n;
int* A = new int[n];
cout << "Введите массив " << endl;
for (int i = 0; i < n; i++) //ввод массива
{
cin >> A[i];
}
for (int i = n - 1; i >= 0; i--)
{
j = i;
while (A[j] == 0 && A[1 + j] != 0 && j + 1 < n)
{
int tmp = A[j + 1];
A[j + 1] = A[j];
A[j] = tmp;
j++;
}
}
cout << "новый массив ";
for (int i = 0; i < n; i++)
{
cout << A[i]<<" ";
}
delete[] A;
return 0;
}