В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Gsjhcf
Gsjhcf
04.11.2022 10:53 •  Информатика

7класснаписать программу, выводящую на экран информацию по заданному образцу: № 1.123456789100000009100000009100000009100000009123456789№ 2.100000000120000000123000000123400000123450000123456000123456700123456780123456789№ 3.111111111100000001100000001100000001100000001100000001100000001100000001111111111№ 4.100000000020000000003000000000400000000050000000006000000000700000000080000000009

Показать ответ
Ответ:
anuaribragimov1
anuaribragimov1
14.09.2022 00:11

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int N;

   cin >> N;

   vector<int>negative;

   vector<int>positive;

   for (int i = 0; i < N; i++) {

       int A;

       cin >> A;

       if (A < 0)

           negative.push_back(A);

       else

           positive.push_back(A);

   }

       

   for (int i = 0; i < negative.size(); i++)

       cout<< negative[i]<<" ";

   for (int i = 0; i < positive.size(); i++)

       cout << positive[i] << " ";

}

0,0(0 оценок)
Ответ:
stalkerCr
stalkerCr
01.05.2020 15:00

я точно не знаю, но уверена, что что модуль можно нимать лишь тогда, когда в этой части уранения больше нет никаких другив компонентов. тоесть, надо перепести все слагаемы в другую часть уравнения.       некоторое я знаю точно: 1) модуль всегда равен положительному числу.2) если под знаком модуля положительное число, то знак модуля просто снимается.3) если под знаком модуля отрицательное число, то у него меняется знак на противоположный, и оно становится положительным.

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота