В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
SashaZanevskaya
SashaZanevskaya
05.03.2022 18:42 •  Информатика

8 кл Дано описание массива С:

char C[3] = { ''A'', ''1'', ''Ю'' };

Чему равно значениеэлемента С[2]?

Показать ответ
Ответ:
kikl33
kikl33
20.01.2022 23:09
1)
from random import random
N = 10
a = []
for i in range(N):
    b = int(random() * 50)
    a.append(b)
print(a)

min = 101
for i in range(N-1):
    s = a[i]+a[i+1]
    if (s < min) and (s % 2 == 1):
        min=s
print(min)

Пример:[41, 35, 16, 7, 29, 9, 16, 28, 10, 6]
23

2)
from random import random
N = 10
a = []
for i in range(N):
    b = int(random() * 50)-25
    a.append(b)
print(a)

k = 0
for i in range(N-1):
    p = a[i]*a[i+1]
    s = a[i]+a[i+1]
    if (p % 2 != 0) and (s > 0):
        k = k+1
print(k)

Пример:[11, 23, 12, -16, 21, 15, -11, -10, 10, 17]
3
0,0(0 оценок)
Ответ:
дэвттвс
дэвттвс
02.09.2021 20:22
16. Найдите ответы на вопросы:Какая картинка используется для выбора цвета в модели HSB?

Место для ввода текста.

Как перевести код цвета из модели RGB в модель CMY?

Место для ввода текста.

Зачем используют цветовую модель Lab?

Место для ввода текста.

17. Найдите ответы на вопросы:

В каких форматах можно сохранить изображение с палитрой?

Место для ввода текста.

Определите размер палитры и глубину цвета при кодировании с палитрой 128 цветов:

глубина цвета битов на пиксель, размер палитры байтов.

Как можно преобразовать рисунок, записанный в формате истинного цвета, в формат с палитрой?

Место для ввода текста.

18. Найдите ответы на вопросы:

Cколько цветов может быть в палитре файлов форматов BMP, GIF, PNG?

От до .

Какие форматы файлов могут хранить анимированные изображения?

Место для ввода текста.

C каких символов начинаются файлы в формате JPEG?

Место для ввода текста.

19. Рисунок размером 10×15 см кодируется с разрешением 300 ppi. Оцените количество пикселей в этом рисунке.

Ширина = пикселей.

Высота = пикселей.

Всего = пикселей.

20. Какова глубина цвета, если в рисунке используется

65536 цветов: битов 256 цветов: битов

212 цветов: битов 27 цветов: битов

16 цветов: битов 4 цвета: битов

21. Сколько байтов будет занимать код рисунка размером 40×50 пикселей в режиме истинного цвета:

Место для ввода текста.

при кодировании с глубиной цвета 8 битов на пиксель:

Место для ввода текста.

при кодировании с глубиной цвета 4 бита на пиксель:

Место для ввода текста.

в черно-белом варианте (два цвета):

Место для ввода текста.

22. Постройте двоичные коды для двухцветных рисунков и запишите их в шестнадцатеричной системе счисления. Обозначайте белые пиксели кодом 1, а чёрные – кодом 0. Выделите фоном группы по 4 бита, которые объединяются в одну шестнадцатеричную цифру.

Какие сложности у вас возникли?

Место для ввода текста.

Как их можно преодолеть?

Место для ввода текста.

23. Постройте черно-белый рисунок шириной 8 пикселей, закодированный шестнадцатеричной последовательностью 2466FF662416. Белые пиксели имеют код 1, чёрные – код 0.

24. Постройте черно-белый рисунок шириной 5 пикселей, закодированный шестнадцатеричной последовательностью 3A53F8816. Белые пиксели имеют код 1, чёрные – код 0.

25. Для жёлтого цвета найдите красную, зеленую и синюю составляющие при 12-битном кодировании (4 бита на канал, 4096 цветов):

R = G = B =

26. Иногда используют 16-битное кодирование цвета (англ. High Color), при котором на красную и синюю составляющую отводится по 5 бит, а на зеленую, к которой человеческий глаз более чувствителен, – 6 бит.

Сколько различных цветов можно закодировать таким образом?

Место для ввода текста.

Определите числовые значения яркостей каждого канала для жёлтого цвета: R = G = B =

27. Сколько места занимает палитра в файле, где используются

64 цвета: = байтов.

128 цветов: = байтов.

N цветов: байтов.

28. Сколько байтов будет занимать код рисунка размером 80×100 пикселей при кодировании с глубиной цвета 12 битов на пиксель?

= байтов.

при кодировании с глубиной цвета N бит на пиксель?

= байтов.

29. Для хранения растрового изображения размером 32×32 пикселя выделено 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения?

Глубина цвета:

Место для ввода текста.

Количество цветов:

Место для ввода текста.

30. Для хранения растрового изображения размером 128128 пикселей выделено 4 килобайта памяти. Каково максимально возможное число цветов в палитре изображения?

Место для ввода текста.

31. При обработке растрового графического файла количество цветов уменьшилось с 256 до 16. Во сколько раз уменьшился размер файла?

32. При обработке растрового графического файла количество цветов уменьшилось с 64 до 4. Во сколько раз уменьшился объём файла?

33. Разрешение экрана монитора – 1024×768 точек, глубина цвета – 16 битов на пиксель. Какой объём памяти (в Мбайтах) требуется для хранения полноэкранного изображения экрана в данном графическом режиме?

Место для ввода текста.

Объяснение:

вот тебе твой вопрос..

за хахаха
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота