В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

99 гуманитарию 1.√(√у-5*у+8) составьте программу.ответ запишите с функций round,int и frac. 2.написать программу.для х,заданного вычислите "у" по формуле у=х в кубе+2,5х в квадрате -х+1 при этом: а)в одном операторе присваивания можно использовать не более одной орифметической операции; б)в программе может быть использовано не более пяти операторов присваивания в)операцию возведения в степень использовать запрещено! 3.составить программу, которая вычислит длину гипотенузы. конечный ответ округлить до 4 цифр после запятой.

Показать ответ
Ответ:
andrew2324
andrew2324
06.10.2020 03:30
1.
var y:real;
begin
write('y = ');
readln(y);
writeln(sqrt(sqrt(y)-5*y+8):5:3);
end.

Пример:
y = 0.09
2.802

2.
var x,y,t1,t2,t3:real;
begin
write('x = ');
readln(x);
t1:=x*x;    // x^2
t2:=x+2.5;  // x+2.5
t3:=t1*t2;  // x^3+2.5*x^2
y:=t3-x;    // x^3+2.5*x^2-x
y:=y+1;     // x^3+2.5*x^2-x+1
writeln('1) y = ',y:5:2);
writeln('2) y = ',x*x*x+2.5*x*x-x+1:5:2);
end.

Пример:
x = 3
1) y = 47.50
2) y = 47.50

3.
var a,b,c:real;
begin
write('a = ');
readln(a);
write('b = ');
readln(b);
c:=sqrt(a*a+b*b);
writeln('c = ',c:6:4);
end.

Пример:
a = 3
b = 4
c = 5.0000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота