В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
jhgdfkjg
jhgdfkjg
10.12.2022 00:17 •  Информатика

Abcpaskal: с клавиатуры вводится строка, состоящая из букв и цифр. написать программу , определяющую количество четных цифр в

Показать ответ
Ответ:
moskvarodina345
moskvarodina345
26.06.2020 06:25
Uses crt;
var s1:string;
    s2:char;
    k,y,x:integer;
begin
     readln(s1);
     k:=0;
     for x:=1 to length(s1) do
         begin
              s2:=s1[x];
              if (ord(s2)<=57) and (ord(s2)>=48) then
                 if ord(s2) mod 2=0 then inc(y);
         end;
     writeln(y);
end.
0,0(0 оценок)
Ответ:
наст55
наст55
26.06.2020 06:25
Var
s1,s2:string;
i,j,k,m:longint;
begin
readln(s1);
k:=length(s1);
s2:='24680';
for i:=1 to k do
  for j:=1 to 5 do
    if s1[i]=s2[j] then inc(m);
writeln(m);
end.
ну вроде так, скомпилируй только перед отправкой или сдачей
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота