В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
emalyustova
emalyustova
07.03.2021 17:28 •  Информатика

Алгоритм с подпрограммой (вс алгоритм).
Вспомнить как составляются подпрограммы (вс алгоритмы) Попробовать написать подпрограмму для рисования квадратика 2х2 и нарисовать 10 квадратов на поле в разных местах.
Составить программу для рисования «автобуса» см. рисунок.
Общее количество команд должно быть менее 67.

Показать ответ
Ответ:
ban20050408
ban20050408
10.07.2022 11:43

1) Натуральное число называется числом Армстронга, если сумма цифр числа, возведенных в N-ю степень, где N - количество цифр в числе, равна самому числу. Напримерт153=1^3 5^3 3^3. Найдитетвсе трехзначныеии четырехзначныеичисла Армстронга

var a,b,c,d,a2:integer;

begin

for a:=100 to 9999 do begin

d:=0;

a2:=a;

while (a2 <> 0) do begin

b:= a2 mod 10;

a2:= a2 div 10;

if a<1000 then c:= (b*b*b)

else c:=(b*b*b*b);

d:= d+c;

end;

if (a = d) then writeln('число армстронга ==> ', a);

end;

end.

2)Авmoморфные числа. Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например: 25 и 625. Напишите программу, которая вводит натуральное число N и выводит на акран все автоморфные числа, не превосходящие N.

var n,i,l:integer; s1,s2:string;

begin

write('n = '); readln(n);

for i:=1 to n do

begin

str(i,s1);

l:=length(s1);

str(i*i,s2);

if s1=copy(s2,length(s2)-l+1,l) then writeln(i,' ',i*i);

end;

end.

3)Модифицированный алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так: нужно заменять большее число на остаток от деления большего на меньшее до тех пор, пока остаток не станет равно нулю; тогда второе число и есть НОД. Напишите программу, которая реализует этот алгоритм.

var a,b,nod,k:integer;

begin

readln(a,b);

k:=0;

while (a<>0)and(b<>0) do

begin

if a>b then a:=a mod b else b:=b mod a;

k:=k+1;

end;

nod:=a+b;

writeln(nod,' ',k);

end.

0,0(0 оценок)
Ответ:
rfhfntkm7p06pep
rfhfntkm7p06pep
29.01.2023 05:55
Системный подход рассматривает явление в целостности его частей, а не по отдельным частям. Так, если вы покупаете машину, то надо смотреть не один ее внешний вид, но и стоимость, а также расход топлива, наличие фирм ремонта и так далее. Нарушение системного подхода ведет к катастрофе, скажем к изменению климата - желание выпускать все больше продукции и строительство предприятий ведет к "тепловому удару".  В биологии нарушение единой системы жизни  в некоторой местности, то есть нарушение биоценоза, также ведет к тяжелым последствиям - излишнее увеличение численности птиц приводит к исчезновению насекомых, среди которых могут быть полезные. А излишнее уменьшение числа птиц ведет к росту числа насекомых и они могут губить леса.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота