В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Sharabyrin
Sharabyrin
05.08.2020 12:45 •  Информатика

C++ Напишите программу, которая сортирует массив, а затем находит максимальное из чисел, встречающихся в массиве несколько раз.

Показать ответ
Ответ:
aalina760
aalina760
23.07.2021 16:28
Для начала надо привести к одной единице изменения:
1гбайт=1024мбайт
1мбайт=1024кбайт
1кбайт=1024байт
иногда для упрощения пересчета используют не 1024, а 1000.
рассчитаем если 1024:
 
3.4мб=3481,6кбайт
3481,6+1364=4845,6кбайт
4845,6кбайт * 1024 = 4961894,4 байт

5.7гб=5836,8мб
5836,8+4537=10373,8 мбайт=10622771,2 кбайт

6341кб=6493184байт
6493184байт+3842байт=6497026 байт
2.5кб=2560байт
6497026 байт*2560 байт= 16632386560 байт

можно перевести учитывая не 1024, а 1000 по этому же принципу, циферки будут попроще немного
0,0(0 оценок)
Ответ:
grange
grange
31.05.2023 09:16
Программа:
const
  n = 5;
  m = 5;
 
var
  a: array[1..n, 1..m] of integer;
  i, j: integer;
 
function check(i: integer): boolean;
var j: integer;
begin
  check := false;
  j := 0;
  repeat
    inc(j);
    if a[i, j] < 0 then
    begin
      check := true;
      exit;
    end;
  until j = m;
end;
 
function search: integer;
var i: integer;
begin
  search := 0;
  i := 0;
  repeat
    inc(i);
    if not(check(i)) then
    begin
      search := i;
      exit;
    end;
  until i = n;
end;
 
begin
  writeln('Введите матрицу ', n, 'x', m,': ');
  i := 0;
  repeat
    j := 0;
    inc(i);
    repeat
      inc(j);
      read(a[i, j]);
    until j = m;
  until i = n;
  writeln('ответ: ', search);
end.
Пример работы программы:
Введите матрицу 5x5:
3 4 2 3 -2
3 -5 -7 -2 1
8 2 5 4 -4
0 1 2 3 4
1 7 2 -5 2
ответ: 4
* Примечание: Если во всех строках есть отрицательные элементы, то ответ будет 0 (можно изменить в самой процедуре)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота