В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Kristina052602
Kristina052602
27.08.2020 16:13 •  Информатика

что в это коде не так . вот условие задачи заранее . С++ Напишите программу, которая возвращает 1, если пользователь ввел слово, начинающееся на гласную букву русского алфавита, и 0 в противном случае.

#include

using namespace std;

int main() {

void slov(char s)

{ char slov[] = { "АаЕеИиОоУуЫыЭэЮюЯя" };

int y=0;

for (int i=0; i<18;i++){if (slov[i] == s)y = 1;}

cout<
return 0;

}

Показать ответ
Ответ:
kristinacelidze167
kristinacelidze167
26.10.2022 09:54

// C# 7.3

using System;

using System.Collections.Generic;

using System.Collections;

using System.Text;

namespace Rextester

{

   public class Program

   {

       public static void Main(string[] args)

       {

           var crypted = "";

 

           for (int i = 0; i < CaesarCipher.Ru.Length; i++)

               Console.WriteLine(CaesarCipher.Decode(i, crypted));

       }

   }

   

   class CaesarCipher

   {

       public static readonly string Ru = "";

       public static readonly string RuD = "";

       private static readonly int defaultStep = 3;

       public static CaesarEncrypted Encode(int step, string source, Func<string, string> translate)

       {

           string translatedData = translate(source);

           var stringBuilder = new StringBuilder();

           foreach (char c in translatedData.ToLower())

           {

               stringBuilder.Append(RuD[Ru.IndexOf(c) + step]);

           }

           return new CaesarEncrypted(step, stringBuilder.ToString());

       }

       public static CaesarEncrypted Encode(int step, string source)

       {

           return Encode(step, source, x => x);

       }

       public static string Decode(CaesarEncrypted source)

       {

           var step = source.Step;

           return Encode(-step + Ru.Length, source.ToString(), x => x);

       }

       public static string Decode(int step, string source)

       {

           return Encode(-step + Ru.Length, source, x => x);

       }

   }

   class CaesarEncrypted : IEnumerable, IEnumerable<char>

   {

       public int Step { get; set; }

       public string Data { get; set; }

       public CaesarEncrypted(int step, string initData)

       {

           Step = step;

           Data = initData;

       }

       public CaesarEncrypted(string initData) : this(int.MaxValue, initData)

       {}

       public IEnumerator<char> GetEnumerator()

       {

           foreach (char c in Data)

               yield return c;

       }

       IEnumerator IEnumerable.GetEnumerator() => (IEnumerator<char>)GetEnumerator();

       public override string ToString() => Data;

       public static implicit operator string(CaesarEncrypted source) => source.ToString();

   }

}

0,0(0 оценок)
Ответ:
hamzmxn66
hamzmxn66
08.01.2021 05:04
•Правильный (равносторонний, или равноугольный) треугольник — это правильный многоугольник с тремя сторонами, простейший из правильных многоугольников. Все стороны правильного треугольника равны между собой, все углы также равны и составляют 60°. В равностороннем треугольнике высота является и биссектрисой, и медианой.
•св-ва квадрата: Длины всех сторон равны.
Все углы квадрата прямые.
Диагонали квадрата равны, взаимно перпендикулярны, точкой пересечения делятся пополам и являются биссектрисами углов.
•св-ва шестиугольника:
Сторона равна радиусу описанной окружности: .
Радиус описанной окружности является биссектрисой угла правильного шестиугольника.
Все углы правильного шестиугольника равны .
• круг всегда равен 360 градусам
• Чтобы найти длину окружности, нужно либо диаметр окружности умножить на π≈3,14
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота