В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
89000566004
89000566004
20.03.2021 18:38 •  Информатика

Дан алгоритм и надо написать его решение на паскале. надо..​

Показать ответ
Ответ:
temik261
temik261
29.09.2022 12:17
Procedure Mean(X,Y:real; Var AMean,GMean:real);
Begin
AMean:=(X+Y)/2;
GMean:=Sqrt(X*Y);
End;
Var
   A,B,C,D,S:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
Write('D = ');ReadLn(D);
WriteLn;
Mean(A,B,S,B);
WriteLn('AMean(A,B) = ',S);
WriteLn('GMean(A,B) = ',B);
WriteLn;
Mean(A,C,S,C);
WriteLn('AMean(A,C) = ',S);
WriteLn('GMean(A,C) = ',C);
WriteLn;
Mean(A,D,S,D);
WriteLn('AMean(A,D) = ',S);
WriteLn('GMean(A,D) = ',D);
End.

A = 1
B = 2
C = 3
D = 4

AMean(A,B) = 1.5
GMean(A,B) = 1.4142135623731

AMean(A,C) = 2
GMean(A,C) = 1.73205080756888

AMean(A,D) = 2.5
GMean(A,D) = 2
0,0(0 оценок)
Ответ:
fZeo0z
fZeo0z
30.08.2021 16:20
Var
   Text,S:string;
   n,k:boolean;
   i:integer;
Begin
Write('Введите текст на русском языке: ');ReadLn(Text);
Text:=LowerCase(Text)+' '; // перевоит текст в нижний регистр
WriteLn(Text); // показывает действие предыдущей строки
For i:= 1 to Length(Text) do
    Begin
    if ('а' <= Text[i])and(Text[i] <= 'я')or(Text[i] = 'ё') then S:=S+Text[i] // записываем русские буквы в S
    else // как только встречаем другой символ, проверяем,
       if Length(S) > 0 then // есть ли в S хоть одна буква,
          Begin // и если есть, то проверяем условие задачки, и выводим слово на экран, если оно истинно
          if (S[1] in 'бвгджзйклмнпрстфхцчшщ')and(S[Length(S)] in 'аоэиуыеёюя') then WriteLn(S);
          S:=''; // далее обнуляем S
          End;
    End;
End.

Пример работы программы:

Введите текст на русском языке: Дан произвольный текст на русском языке. Написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
дан произвольный текст на русском языке. написать программу, которая выводит слова, начинающиеся на согласную и заканчивающиеся гласной буквой.
на
программу
которая
слова
начинающиеся
на
согласную
заканчивающиеся
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота