В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
kymbat2016
kymbat2016
23.03.2023 12:25 •  Информатика

Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3 на языке pascal желательно

Показать ответ
Ответ:
volkovaar2000
volkovaar2000
02.10.2020 01:35
var   a: array [1..30] of integer;
i,k: integer;
begin

k:=0;
все в цикле (примерно так: for i:=1 to 10 do...)(это чтобы прокручивать цикл)
if ((a[i] mod 2=1) and (a[i] mod 3=0)) then k=k+1;
writeln(k);end.
что-то вроде этого,я уже точно не помню язык pascal; 
0,0(0 оценок)
Ответ:
1Радуга1
1Радуга1
02.10.2020 01:35
Program E08;
  uses crt;
    var
      X: array[-1000..1000] of integer;
      S,i,k: integer;
begin
  clrscr;
  writeln('Введите массив X:');
  for i:=1 to 10 do
    begin
      write('X[',i:2,'] ==> ');
      readln(X[i])
    end;
      for i:=1 to 10 do
    write(X[i],' ');
    writeln;

  K:=0;

    for i:=1 to 10 do
    begin
      S:=X[i] mod 3;
      if S = 0 then
        K:=K+1
    end;
      writeln('ответ: ',K)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота