В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
IbraevaLisa
IbraevaLisa
14.07.2021 01:18 •  Информатика

Дан массив целых чисел А(25). Составить программу для вычисления суммы нечётных элементов массива.

Показать ответ
Ответ:
diana1156
diana1156
24.02.2022 13:35
Const
  gl = ['а', 'е', 'ё', 'и', 'о', 'у', 'ы', 'э', 'ю', 'я'];

var
  w1, w2: string;
  m: set of char;
  c: char;
  i: integer;

begin
  Writeln('Введите первое "слово"');
  Readln(w1);
  Writeln('Введите второе "слово"');
  Readln(w2);
  m := [];
  w1 := LowerCase(w1);w2 := LowerCase(w2);
  for i := 1 to length(w1) do
    if w1[i] in gl then Include(m, w1[i]);
  for i := 1 to length(w2) do
    if w2[i] in m then Exclude(m, w2[i]); 
  Writeln('Гласные, присутствующие в первом слове и отсутствующие во втором:');
  foreach c in m do Write(c, ' ');
  Writeln
end.

Тестовое решение:
Введите первое "слово"
Дай, Джим, на счастье лапу мне!
Введите второе "слово"
Сергей Есенин
Гласные, присутствующие в первом слове и отсутствующие во втором:
а у
0,0(0 оценок)
Ответ:
chuksin2008
chuksin2008
28.06.2022 15:02
Var A: array[1..20, 1..20] of integer;
m, n, k, i, j: integer;
begin
randomize;
repeat
write('Введите число столбцов и строк через пробел: ');
readln(n, m);
until (n in [1..20]) and (m in [1..20]);
for i := 1 to m do begin
for j := 1 to n do begin
A[ i, j ] := random(19) - 9;
write(A[i, j]:5);
end;
if odd(i) then writeln(' ') else writeln;
end;
writeln;
writeln('Заменяем отрицательные числа на нули, положительные - на единицы:');
writeln;
for i := 1 to m do begin
for j := 1 to n do begin
if A[ i, j ] <= 0 then A[ i, j ] := 0
else A[ i, j ] := 1;
write(A[i, j]:5);
end;
if odd(i) then writeln(' ') else writeln;
end;
end.

p.s: не совсем понятно последнее задание - вывести нижнюю треугольную матрицу. Сделать новую или что?
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота