В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
sofikolomiets04
sofikolomiets04
11.01.2022 07:42 •  Информатика

Дан массив целых чисел из n элементов сформированный случайным образом. определить, сколько в нем чисел кратных 7 написать программу в паскаль

Показать ответ
Ответ:
dvolzhenkov
dvolzhenkov
08.10.2020 07:02
Var
  a, k, n, i, sum: integer;
 
begin
  read(n, k);
  for i := 1 to n do
  begin
    read(a);
    if a mod k = 0 then sum := sum + a;
  end;
  writeln(sum) ;
end.

где k - заданное число которому должны быть кратны элементы массива
n - кол-во элементов массива
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота