В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Катя132211111
Катя132211111
14.01.2022 08:30 •  Информатика

Дан массив чисел A. Нам необходимо определить текущую сумму элементов массива ArraySum [i] = sum (A[0]… A[i]). Верните массив с текущей суммой чисел. Текущая сумма получается следующим образом: Массив A состоит из элементов 1,2,3,4. Результат суммирования А = 1,3,6,10. То есть 1, 1+2 (3), 1+2+3 (6), 1+2+3+4 (10). Входные данные В единственной строке входного файла INPUT записан массив А из целых чисел 1 <=Длина массива <= 1000. Элементы массива -10^6 <= А[i] <= 10^6. Выходные данные В единственную строку выходного файла OUTPUT нужно вывести массив А удовлетворяющий условию.


Дан массив чисел A. Нам необходимо определить текущую сумму элементов массива ArraySum [i] = sum (A[

Показать ответ
Ответ:
24vwyda
24vwyda
03.12.2020 10:45

N = input().split(',')

arr = []

arr2 = []

for i in N:

   i = int(i)

   n = sum(arr2) + i

   arr2.append(i)

   arr.append(n)

print(arr)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота