В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
sofaTV
sofaTV
24.02.2021 14:31 •  Информатика

Дан массив размерностью 5. Найти сумму элементов массива оканчивающихся на 7. Заполнить элементы массива с клавиатуры.

Показать ответ
Ответ:
Nazarkadm
Nazarkadm
25.03.2023 04:59

#include <stdio.h>

#include <iostream>

#include <locale.h>

#include <ctime>

int main() {

setlocale(LC_ALL, "rus");

system("chcp 1251");

const int SIZE = 256;

int i, j, ch;

char str[SIZE];

std::cout << "Your string, please" << std::endl;

for (i = 0; i < SIZE - 1 && (ch = getchar()) != -1 && ch != '\n'; i++) {

 str[i] = ch;

}

std::cout << "Изначальная строка:\n" << str << "\n\n" << std::endl;

for (i = 0; i < SIZE - 1; i++) {

 if (str[i] == '.') {

  if (str[i + 1] == '.' && str[i + 2] == '.') {

   i += 2;

   continue;

  }

  else {

   for (j = SIZE - 3; j > i; j--) {

    str[j + 2] = str[j];

   }

   str[i + 1] = '.';

   str[i + 2] = '.';

   i += 2;

  }

 }

}

std::cout << "Измененная строка:\n" << str << "\n\n" << std::endl;

return 0;

}

0,0(0 оценок)
Ответ:
яна200320032003
яна200320032003
23.11.2020 07:47

Программа на Python приведена ниже

Объяснение:

https://imgur.com/a/zEYf69b (или скриншот, если не откроется ссылка)

Ваша программа:

1) Вы считываете все в одну строку, что не соответствует главному условию задачи: в файле даны строки, а не одна строка. На скриншоте приведено верное написание: пишем цикл for s in file.readlines(), так мы обозначим, что строк больше одной.

2) Для подсчета количества букв логично использовать встроенный метод str.count(''), однако если вы решили обойти это и использовать специальные переменные для подсчета (такой вариант решения возможен, хотя и менее эффективен с точки зрения написания кода), верное решение таким путем приведено на скриншоте №2

   2.1) В программе №2 необходимо не забывать обнулять переменные

         после каждого цикла, как это указано на скриншоте №2


Текстовый файл содержит строки различной длины. Общий объём файла не превышает 1 Мбайт. Строки содер
Текстовый файл содержит строки различной длины. Общий объём файла не превышает 1 Мбайт. Строки содер
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота