В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
geroi29
geroi29
04.08.2020 21:51 •  Информатика

Дан массив в(n,n).В каждом строке найти количество элементов,которые по модулю больше 50.Составить программу Паскаль очень надо

Показать ответ
Ответ:
svetlana50036
svetlana50036
13.05.2020 08:03

Работа с двухмерном массивом

Объяснение:

Двухмерные массивы можно представить в виде матрицы где главная ось начинается с левого верхнего угла заканчивая нижним правым углом.

{ 1  2  3  4 }

{ 1  2  3  4 }

{ 1  2  3  4 }

{ 1  2  3  4 }

так выглядит двухмерный массив,если пройтись по диагонали нам нужно вывести числа 1 2 3 4

Написал программу которая выводит главная диагональ на языке С#

учитывать что в данном языке программирования индексы массива идут с нулевого элемента,в коде я заполнил наш массив размером 4 на 4 (16 ячеек) значениями 1 2 3 4 каждый столбец и строчку,потом вывел их на экран.


Вопрос звучит так: Заполнить массив С(4,4). Вывести на экран элементы главной диагонали. Но мне бы
Вопрос звучит так: Заполнить массив С(4,4). Вывести на экран элементы главной диагонали. Но мне бы
0,0(0 оценок)
Ответ:
nikgtacs59
nikgtacs59
16.12.2020 01:19

amount = 0

while True:

   cost = int(input("Стоимость товара (0 - покупок больше нет): "))

   if cost == 0:

       break

   amount += cost

print("Стоимость всех покупок:", amount)

Объяснение:

amount = 0 // Сумма = 0

while True: // Пока истинно

   cost = int(input("Стоимость товара (0 - покупок больше нет): ")) // Вводим стоимость с клавиатуры

   if cost == 0: // Если стоимость = 0

       break // Выходим из цикла

   amount += cost // Добавляем к сумме стоимость

print("Стоимость всех покупок:", amount) // Выводим ответ

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота