В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Alisa45612
Alisa45612
04.09.2021 02:27 •  Информатика

Дан одномерный массив из n целых чисел. составить программу нахождения максимального и минимального элементов.

Показать ответ
Ответ:
Vika0095
Vika0095
10.07.2020 19:29
Var a:array of integer;
  i,n,mn,mx: integer;
begin
  write('размерность массива = ');
  readln(n);
  SetLength(a, n);
  for i := 0 to n-1 do begin
    write('a[',i,']=');
    readln(a[i]);
  end;
  
  mn := a[0]; 
  mx := a[0];
  for i := 1 to n-1 do begin
    if mn > a[i] then mn := a[i];
    if mx < a[i] then mx := a[i];
  end;
  
  writeln('минимальный элемент = ', mn);
  writeln('максимальный элемент = ', mx);
end.
  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота