В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
228446
228446
02.06.2022 06:42 •  Информатика

Дан трёхмерный массив м(1: 100, 1: 20, 1: 75) вещественного типа
а) составте алгоритм вычисления суммы всех положительных элементов массива
б) составьте алгоритм, позволяющий выяснить, каких элементов - положительных или отрицательных- в массиве больше и на сколько.

Показать ответ
Ответ:
senyadubra
senyadubra
10.10.2020 14:44

#include <iostream>

#include <time.h>

using namespace std;

void print_array3(int*** mat, int n, int m, int z) {

for (size_t i = 0; i < n; i++) {

 for (size_t j = 0; j < m; j++) {

  for (size_t k = 0; k < z; k++) {

   cout << mat[i][j][k] << " ";

  }

  cout << endl;

 }

 cout << endl;

}

}

pair<int***, pair<int, int>> auto_input_array3_and_counter_positive(int*** mat, int n, int m, int z) {

int sum = 0;

int positive = 0;

for (size_t i = 0; i < n; i++) {

 for (size_t j = 0; j < m; j++) {

  for (size_t k = 0; k < z; k++) {

   mat[i][j][k] = rand() % 200 - 100;

   if (mat[i][j][k] > 0) {

    positive++;

    sum += mat[i][j][k];

   }

  }

 }

}

return make_pair(mat, make_pair(positive, sum));

}

int main()

{

srand(time(NULL));

setlocale(LC_ALL, "Russian");

int n = 100, m = 20, z = 75;

int*** array = new int** [n];

pair<int***, pair<int, int>>  pair_array_and_positive_sum;

for (size_t i = 0; i < n; i++) {

 array[i] = new int* [m];

 for (size_t j = 0; j < m; j++) {

  array[i][j] = new int[z];

 }

}

pair_array_and_positive_sum = auto_input_array3_and_counter_positive(array, n, m, z);

print_array3(pair_array_and_positive_sum.first, n, m, z); // ЕСЛИ НЕ НАДО ВЫВОДИТЬ, ТО ЗАКОММЕНТИРОВАТЬ

cout << "Сумма всех положительных элементов в массиве равна: " << pair_array_and_positive_sum.second.second << endl;

if (pair_array_and_positive_sum.second.first > n* m* z - pair_array_and_positive_sum.second.first) {

 cout << "Положительных чисел больше на " << n * m * z - (n * m * z - pair_array_and_positive_sum.second.first) << endl;

}

else {

 cout << "Отрицательных чисел больше на " << n * m * z - 2 * pair_array_and_positive_sum.second.first << endl;

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота