В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Дана матрица А(nxn). Написать программу, которая упорядочивает элементы каждого столбца этой матрицы по убыванию написать программу на С++, заранее

Показать ответ
Ответ:
dgrigoref
dgrigoref
19.06.2022 11:18
Программа, которая использует два массива

var 
c, a: array[1..20] of integer; 
i: integer;
begin 
write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 1 to 20 do   begin   
a[i] := c[20 - i + 1];   
write(a[i], ' '); 
end;  
end.

ИЛИ  Программа не использующая два массива, а просто переворачивающая первый

var 
c: array[1..20] of integer; 
i: integer;
begin  write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 20 downto 1 do  write(c[i], ' '); 
end.

Обе программы работают!
0,0(0 оценок)
Ответ:
мария2384
мария2384
25.02.2022 09:45

Программист - это очень интересная и занимательная профессия, используемая практически в любой отрасли, а также и в сельском хозяйстве.  Хороший программист обязан быть предельно внимательным и вдумчивым, склонным к анализу и скрупулезному труду. Он должен быть человеком практичного характера. Программист должен сочетать в себе как гуманитарный, так и технический склад ума. При всём при этом, эти люди должны обладать фантазией и творческим мышлением.

В век компьютерных технологий – это актуальная профессия для нашего времени. Так как роботизация охватывает всё новые и новые сферы жизнедеятельности, я хочу принимать активное участие в их создании.

Также, профессия программиста становится одной из самых востребованных и высокооплачиваемых специальностей в мире. Несложно понять принцип работы машины, ведь все они функционируют на основе одних и тех же алгоритмов. Изучив компьютерную науку, можно стать создателем «нового мира».  Мир, который привлечет миллионы и миллионы пользователей.  

Я считаю, что в работе самое главное квалификация и умения, потому что опыт приходит с годами, а знания необходимы с первых дней работы по специальности. Каждый человек должен заниматься одним делом всю свою жизнь, чтобы стать настоящим профессионалом и быть полезным своей стране и своему народу.  

От выбора профессии зависит будущее человека. Я надеюсь, что сделал правильный выбор. Ведь это - моя жизнь, мой выбор, мой мир, в котором мне предстоит жить.

надеюсь
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота