В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
KsushaBushueva
KsushaBushueva
09.06.2020 02:51 •  Информатика

дано целое двухзначное число x составьте программу вычисления суммы и произведения цифр трезначного числа x значение x ввести с клавиатуры

Показать ответ
Ответ:
lbogdan2
lbogdan2
04.02.2021 14:40

Вариант для числа, с любым количеством цифр:

x = abs(int(input()))

s, pr = 0, 1

while x > 0:

   s += x % 10

   pr *= x % 10

   x //= 10

print(s)

print(pr)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота