В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
110217
110217
09.11.2021 03:15 •  Информатика

Дано натуральное двузначное число. составить программу определения, является ли сумма его цифр двузначным числом. если нет, то через сколько чисел встретиться первое двузначное число, удовлетворяющее этому условию.на паскале

Показать ответ
Ответ:
marta4191
marta4191
09.10.2020 11:48

var

x,x1:integer;

begin

readln(x);

if (x div 10 + x mod 10 >= 10) then writeln ('Является')

else begin  x1:=x; while (x1 div 10 + x1 mod 10 < 10) do x1:=x1+1; end;a

if (x div 10 + x mod 10 < 10) then writeln('Нужно увеличить на ',x1-x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота