Даны числа n и m. создайте массив a[n][m] и заполните его, как показано на примере. входные данные программа получает на вход два числа n и m. выходные данные программа должна вывести полученный массив. примеры входные данные 4 10 выходные данные 0 1 3 6 10 14 18 22 26 30 2 4 7 11 15 19 23 27 31 34 5 8 12 16 20 24 28 32 35 37 9 13 17 21 25 29 33 36 38 39 pascal
N,M,D,N2,i,C,j,M2,k:integer;
begin
N:=0;D:=0;k:=0;
write('Введите N = ');Readln(N);
write('Введите M = ');Readln(M);
For i:= 1 to M do begin
M2:=1;
For N2:=i downto 1 do begin
if M2<=N then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
//после побочной диагонали
For D:=2 to N do begin
M2:=D;
For N2:=M downto 1 do begin
IF (M2<=N) and (N2<=M) then begin
mas[M2,N2]:=k;
k:=k+1;
M2:=M2+1;
end;
end;
end;
For i:=1 to N do begin Writeln();
for j:=1 to M do
write(mas[i,j],' ');
end;
end.