В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
DANCER131
DANCER131
03.04.2023 07:18 •  Информатика

Даны две дроби a/b и c/d (a,b,c,d - натуральные числа). составить программу деления дроби на дробь. ответ должен быть несократимой дробью. использовать подпрограмму алгоритма евклида для определения нод

Показать ответ
Ответ:
ЛадаПодмаркова
ЛадаПодмаркова
03.10.2020 11:43
Var  a, b, c, d, Num, Denom, Divis: Integer;  
Function gcd(a, b: Integer): Integer;
Var Temp: Integer;
Begin
  While b > 0 Do
  Begin
    Temp := b;
    b := a mod b;
    a := Temp
  End;
  gcd := a;
End;
Begin
  WriteLn('Введите числа A, B, C, D: ');
  Read(a, b, c, d);
  Num := a * d;
  Denom := b * c;
  Divis := gcd(Num, Denom);
  WriteLn(Num div Divis, '/', Denom div Divis);
End.
0,0(0 оценок)
Ответ:
135670ш8ге5
135670ш8ге5
03.10.2020 11:43
Function NOD(x,y:integer):integer;
begin
while (x<>0)and(y<>0) do
 if x>y then x:=x mod y else y:=y mod x;
NOD:=x+y;
end;
var a,b,c,d,n,z1,z2:integer;
begin
writeln('1-я дробь (числитель и знаменатель):');
readln(a,b);
writeln('2-я дробь (числитель и знаменатель):');
readln(c,d);
n:=nod(a*d,b*c);
z1:=a*d div n; 
z2:=b*c div n;
writeln(z1,'/',z2);
end.

Пример:
1-я дробь (числитель и знаменатель):
5 6
2-я дробь (числитель и знаменатель):
2 8
10/3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота