В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
cmpunk559
cmpunk559
09.03.2020 18:40 •  Информатика

Даны две точки в плоской прямоугольной системе координат Напишите программу определяющую которая из точек находящиеся ближе к началу координат.
ОЧЕНЬ НАДО

Показать ответ
Ответ:
anhelinayeremenko30
anhelinayeremenko30
07.07.2021 16:38
Допустим в январе 31 день. Предположим что осадки это целые числа и число 0 свидетельствует об отсутствии осадков.

Вот функция возвращающая дни без осадков

C#Выделить код1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20  private int[] NetOsadkov(ref int[]Pogoda)         {             int[] error = {-1};             int[] PogodaBezOsadkov = { 0 };             List<int> osadki = new List<int>();             int NetOsadkov = 0;                     if (Pogoda.Length < 31)             {                 return error;             }             for (int i = 0; i < Pogoda.Length;i++ )             {                 if (Pogoda[i] == NetOsadkov)                 {                     osadki.Add(i+1);                 }             }             PogodaBezOsadkov = osadki.ToArray();             return PogodaBezOsadkov;         }Проверяем..

C#Выделить код1 2 3 4 5 6 7 8  int[] JanuaryWeather = {123,4535,756,45,0,67,22,3453,765,35,456,35,0,35,45,76,6,567,35,6543,0,35,456,58,467,4657,458,48,0,67,745};             string result = string.Empty;                         foreach (int val in NetOsadkov(ref JanuaryWeather))             {                 result += val.ToString() + ',';             }             MessageBox.Show(result+" "+"Января была погода без осадков");
0,0(0 оценок)
Ответ:
DDaVV
DDaVV
09.11.2021 16:39
Var a, b: integer;
var c: string;
begin
writeln('Введите 1 число.');
readln(a);
writeln('Введите 2 число.');
readln(b);
writeln('Знак операции.');
readln(c);
if c='*' then writeln(a*b);
if c='/' then writeln(a/b);
if c='-' then writeln(a-b);
if c='+' then writeln(a+b);
end.
2 ЗАДАЧА 
var a, b: real;
begin
writeln('Зарабаток Пети:');
readln(a);
writeln('Зарабаток Петрова:');
readln(b);
if a>b then writeln('Петя заработал больше Петрова.')
else if a=b then writeln('Петров и Петя заработали одинаково.')
else
writeln('Петров заработал больше Пети.');
writeln('Среднее: ', (a+b)/2);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота