В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
мирби1
мирби1
12.01.2022 22:21 •  Информатика

Добрый день. как в паскале чертежник написать программу, чтобы нарисовать цифры 1,2,3,4,5

Показать ответ
Ответ:
Yulyaisaeva2005
Yulyaisaeva2005
02.07.2021 06:03

program jumping;

var

 i, j, temp: integer;

 B: array [1..10] of integer;

begin

 for i := 1 to 10 do  

   read(B[i]);  

 for i := 1 to 9 do

   for j := 1 to 10 - i do

     if (B[j] < B[j + 1]) then

     begin

       temp := B[j];

       B[j] := B[j + 1];

       B[j + 1] := temp;

     end;

 writeln('Первое место: ', B[1]);

 writeln('Второе место: ', B[2]);

 writeln('Третье место: ', B[3]);

end.

Объяснение:

program jumping;  // Название программы

var

 i, j, temp: integer;  // Целочисленные переменные:

i - переменная счетчик для цикла forj - переменная счетчик для цикла fortemp - переменная для временного хранения значений массива

 B: array [1..10] of integer;  // Целочисленный массив из 10 чисел

begin  // Начало программы

 for i := 1 to 10 do // Идём с первого по десятый элементы массива

   read(B[i]); // Ввод значений массива

// Сортировка массива в порядке убывания

 for i := 1 to 9 do  // Идём с первого по девятый элементы массива

   for j := 1 to 10 - i do  // Идём с первого по 10 - i элементы массива

     if (B[j] < B[j + 1]) then  // Если последующий элемент больше предыдущего

     begin  // Начало цикла

       temp := B[j];  // Временная переменная = значению массива B с индексом j

       B[j] := B[j + 1];  // Значение массива B с индексом j = значению массива B с индексом j + 1

       B[j + 1] := temp;  // Значение массива B с индексом j = значению временной переменной

     end;  // Конец цикла

 writeln('Первое место: ', B[1]);  // Вывод ответа

 writeln('Второе место: ', B[2]);  // Вывод ответа

 writeln('Третье место: ', B[3]);  // Вывод ответа

end. // Конец программы

0,0(0 оценок)
Ответ:
sladkoegka03
sladkoegka03
06.02.2020 00:22

17. num = 23

# 1 вариант - преобразуем число в строку, разбиваем на цифры

string = str(num)

if int(string[0]) < int(string[1]): # если первая цифра меньше второй

   string = string[1] + string[0] #меняем их местами

num = int(string)

# 2 вариант - остатком от деления на степени 10

# остаток от деления на 10 - первая цифра числа, остаток от деления на 100 - вторая и так далее

if num % 10 < num % 100: #если первая цифра меньше второй

   num = num % 10 * 10 + num % 100

21.

num = 1234

# 1 вариант - преобразуем число в список и находим сумму цифр

string = str(num)

lst = [int(n) for n in string] # учили списковое включение? если нет, смотри следующий код

lst = []

for n in string:

   lst.append(int(n)) # это все если не учили списковое включение

# второй вариант - остатки от деления на 10 суммируем вручную

first = num % 10

sec = num % 100

th = num % 1000

four = num % 10000

result = first + sec + th + four

result = sum(n)

Объяснение:

Функция sum() возвращает сумму элементов списка

Если будут вопросы - пиши

Если пригодилось - оцени ответ ;)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота