В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Eugene1000
Eugene1000
11.10.2022 02:23 •  Информатика

Информатика. 1)написать программу, которая запрашивает одно число-количество учащихся в классе, и выводит минимальное количество парт, необходимое для рассадки по 2 человека. 2)написать программу, которая запрашивает одно натуральное пятизначное число, и выводит его третью цифру. 3)для покраски стен и пола комнаты шириной а метров, длинной b метров и высотой с метров(а,b и с-целые числа) необходимое закупить краску. известно, что одной банки крачки хватает на покраску k кв.метров поверхности.найти минимальное необходимое количество банок краски. прогорамма должна получать на выход четыре числа-ширина, высота, длина и количество кв.метров, на которое хватает одной банки краски, и выводит необходимое количество банок.

Показать ответ
Ответ:
poladasadov
poladasadov
05.10.2020 08:16
{1}
var
n : longint;
begin
readln (n);
write ( (n div 2) + (n mod 2));
end.

{2}
var
n : longint;
begin
repeat
readln (n);
until (n in [10000..100000]) and (abs(n) = n);
write ( ((n mod 1000) - (n mod 100)) div 100 );
end.

{3}
var
a, b, c, sqrM, sum : longint;
begin
readln (a, b, c, sqrM);
sum:=(((a+b)*c)*2 + a*b) div sqrM;
if a+b)*c)*2 + a*b) mod sqrM)<>0 then inc(sum);
write (sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота