В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
leraleralera13
leraleralera13
09.04.2022 18:03 •  Информатика

Информатика 9 класс Составить программу самостоятельно: Найти произведение чисел из

отрезка [1;10]​

Показать ответ
Ответ:
contemplation22
contemplation22
09.02.2022 20:52
На языке Java. Программа складывает и отрицательные и положительные числа.

class SumNum{
 public static void main(String args[]){
  try{
   long sumNum=0,numSum=new Long(new java.io.BufferedReader(new java.io.InputStreamReader(System.in)).readLine());
   do sumNum+=numSum;while((numSum>0?--numSum:++numSum)!=0);System.out.print("Результат "+sumNum);
  }catch(java.io.IOException io){
   System.out.println(" - Ошибка ввода!\n"); main(null);
  }catch(NumberFormatException nf){
   System.out.println(" - Введите целочисленное значение!\n"); main(null);
  }
 }
}
0,0(0 оценок)
Ответ:
theslomsmon
theslomsmon
10.11.2020 21:39
#include <iostream>
using namespace std;
int main()
{
setlocale (0,"");
int n1,n2,n3,p1,p2,p3;
cout<<"введите количество учеников в каждом классе"<<endl;
cout<<"1-";
cin>>n1;
cout<<"2-";
cin>>n2;
cout<<"3-";
cin>>n3;
    p1=n1/2; if (n1%2!=0) p1++;
    p2=n2/2; if (n2%2!=0) p2++;
    p3=n3/2; if (n3%2!=0) p3++;
cout<<"для первого класса - "<<p1<<endl;
cout<<"для второго класса - "<<p2<<endl;
cout<<"для третьего класса - "<<p3<<endl;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота