В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
голова332
голова332
06.11.2020 06:48 •  Информатика

Информатика чему равна сумма элементов массива а[0] и a[5] сформированного следующим образом? ​


Информатика чему равна сумма элементов массива а[0] и a[5] сформированного следующим образом? ​

Показать ответ
Ответ:
alina3741
alina3741
07.06.2021 05:29
1) Если говорить о передаче сообщения в нашей жизни, при личном общении, то подойдёт такой вид рассуждений:
а)сообщение содержит информацию для конкретного человека - "Иванов, иди к доске"
б) сообщение содержит информацию для НЕ конкретного человека - "Сегодня всем классом идём на выставку современного искусства"
2) Если говорить о передаче сообщения в Интернете, то пойдёт такой вид рассуждений:
а) сообщение содержит информацию для конкретного человека - например написать сообщение человеку в социальной сети.
б) сообщение содержит информацию для НЕ конкретного человека - Написать сообщение на какую-то публичную страницу (блог, новости и т.д)
0,0(0 оценок)
Ответ:
vikysikrusinova
vikysikrusinova
10.07.2022 22:52

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

#include <stdio.h>

#include <math.h>

#include <string.h>

#include <iostream>

int main(void) {

   struct NOTE {

       char name[100];

       char family[100];

       int tele[15];

   };

   

   struct NOTE note[5];

   

   int i;

   

   

   

   for(i=0;i<5;i++) {

       printf("note %d:\n",i);

       printf("name?: "); scanf("%s",&note[i].name);

       printf("family?: "); scanf("%s",&note[i].family);

       printf("telephone?: "); scanf("%d",&note[i].tele);

   }

   int z[15];

   printf("telephone: ");scanf("%d",z[]);

   for(i=0;i<5;i++)

       if (strcmp(note[i].tele,z)==0){ //<ТУТ СЦУКА РУГАЕТСЯ,НЕ ПОЙМУ ПОЧЕМУ ХЛП

           printf("name: %s\n family %s\n telephone %d\n",note[i].name,note[i].family,note[i].tele);

       }

   char t[40];

   printf("name: "); scanf("%s",t);

   for(i=0;i<5;i++)

       if (strcmp(note[i].name,t)==0){

           printf("name: %s\n family %s\n telephone %d\n",note[i].name,note[i].family,note[i].tele);

       }

   

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота