В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
zulya24
zulya24
12.05.2023 13:43 •  Информатика

Информатика, паскаль напишите программу, перемещающую все нулевые элементы в конец массива 80 очков,

Показать ответ
Ответ:
Mrkeu
Mrkeu
27.08.2020 12:13

const n = 10;

var

 mas: array [1..n] of integer;

 i,j,h:integer;

begin

randomize;

for i := 1 to n do

 begin

   mas[i] := random(3);

   write(' ',mas[i],' ');

 end;

 writeln();

for i := 1 to n - 1 do

 for j := 1 to n - i do

   if(mas[j] = 0) then

     begin

       h := mas[j];

       mas[j] := mas[j + 1];

       mas[j + 1] := h;

     end;

for i := 1 to n do

   write(' ',mas[i],' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота