В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ushanoval
ushanoval
13.03.2020 02:20 •  Информатика

/ивт 9 класс делфи / паскаль/ 50 напишите программу, которая по данному натуральному числу n выводит все его простые натуральные делители с учетом кратности. время работы программы должно быть пропорционально корню из n. входные данные программа получает на вход одно число n< 2^31. выходные данные программа должна вывести все простые натуральные делители числа n с учетом кратности в порядке неубывания. примеры входные данные 6 выходные данные 2 3

Показать ответ
Ответ:
Ксения200612
Ксения200612
04.10.2020 00:52
Var
 n,d,k:int64;
begin
 read(n);
 d := 2; k := 4;
 while k <= n do
  begin
  while n mod d = 0 do
    begin
    write(d,' ');
    n := n div d;
    end;
  k := k + 2*d + 1;
  d := d + 1;
  end;
 if n > 1 then write(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота